anpera.net
http://anpera.homeip.net/phpbb3/

LotGD 1.1.0 - Rasse - Vampir
http://anpera.homeip.net/phpbb3/viewtopic.php?f=53&t=3185
Seite 1 von 1

Autor:  the_Cr0w [ Sa 09 Dez, 2006 16:09 ]
Betreff des Beitrags:  LotGD 1.1.0 - Rasse - Vampir

Hier ist mein erstes richtiges Modul

Features:
Version 1.0 vom 9.12.2006
*Vampir als Rasse verfügbar
*Vampire sind stärker als andere Rassen und können sich regenerieren
*neue Stadt
*Fürtsenhalle (Versammlungsort)
*andere Rassen können zu Vampiren werden

Version 1.1 vom 10.12.2006
*Vampire müssen Blutrinken
*wenn sie zu wenig Blut trinken sterben sie
*Vampire können auf Opfersuche gehn :evil:

Version 1.2 vom 16.12.2006
*ein paar Bugfixes

kommt noch:
*Vampirjäger

Dateianhänge:
Dateikommentar: Version 1.2
racevampir1.2.zip [6.23 KIB]
196-mal heruntergeladen

Autor:  the_Cr0w [ So 10 Dez, 2006 15:40 ]
Betreff des Beitrags: 

UPDATE AUF VERSION 1.1

Autor:  the_Cr0w [ Sa 16 Dez, 2006 11:57 ]
Betreff des Beitrags: 

bitte schreibt mal ein feedback wenn ihr das modul getestet habt

Autor:  Nightborn [ Sa 16 Dez, 2006 12:29 ]
Betreff des Beitrags: 

Hier bitte:

Zitat:
/*
* Copyright (C) 2006 the_Cr0w (aka Vancha March)
* Email: c.herold@inode.at
* Homepage: http://www.logd-diablo.at
*
* Plattform: LOTGD - 1.1.0 DragonPrime Edition
* racevampir.php
*/
// translator ready
// addnews ready
// mail ready


Du hast offensichtlich einfach ein Modul genommen und die Texte ersetzt... und zwar ein Coremodul... aber irgendwie finde ich

Zitat:
"author"=>"`@Vancha March",


... kann nicht so ganz sein, oder?
Also hast Du hier gegen die CCL gerade verstoßen...

bitte stell das originale Copyright wieder her, und nenn Deine Rasse z.B. "Race Vampire, based on racedwarf by Eric Stevens". Und nenn dich als "modified by Vancha March" oder "Vancha March, originally Eric Stevens".

Nur mal so....

Du hast zwar das ursprüngliche Modul erweitert, aber die Vorlage war eben ein anderes... und zwar nicht nur "zum Hinguggen", sondern Du hast es editiert.

Getestet hab ich es nicht, aber Feedback kann ich geben.

Autor:  the_Cr0w [ Sa 16 Dez, 2006 19:50 ]
Betreff des Beitrags: 

ich hab die bereits vorhandenen rassen als vorlage benutzt damit ich weiß wie es aussehn soll.

$this->bbcode_second_pass_code('', '// translator ready
// addnews ready
// mail ready')

das hab ich drin gelassen weil ich schon scripts gesehn hab bei denen solche dinge wichtig sind damit sie richtig angezeigt werden.

Autor:  Kevz [ Sa 16 Dez, 2006 19:53 ]
Betreff des Beitrags: 

Niemals... das hat keinen zusammenhang damit! Und die Aussage von wegen "die sind nötig damit es richtig angezeigt wird" ist völlig irrelevant, weil die Kommentare in sofern nicht das Script oder Sonstiges beeinflussen tun!

Autor:  the_Cr0w [ Sa 16 Dez, 2006 20:15 ]
Betreff des Beitrags: 

sieh dir mal das blogger script wordpress an. dort gibts sowas

Autor:  Kevz [ Sa 16 Dez, 2006 20:36 ]
Betreff des Beitrags: 

Dennoch hat "Wordpress" insofern, rein garnichts mit LotGD zu tun und auch sozusagen keinen zusammenhang!
Kommentare, dienen hauptsächlich dazu um Codefragmente zu Beschreiben ggf. um Copyright rechte & co zu kennzeichnen. Also ist in sofern deine aussage, das es von nöten ist irrelevant.
Also müssten deiner Aussage nach, fast alle Scripte der LotGD Module & co von Programmierern nicht richtig angezeigt werden?

Autor:  the_Cr0w [ Sa 16 Dez, 2006 20:46 ]
Betreff des Beitrags: 

UPDATE AUF VERSION 1.2

Autor:  the_Cr0w [ Sa 16 Dez, 2006 20:58 ]
Betreff des Beitrags: 

so hab ich das nicht gemeint. ich hab nicht gewusst ob es nötig is. deswegen hab ich es sicherheitshalber drinn gelassen. wenn ich so überleg hätte ich es auch einfach ausprobieren können. aber es is immer besser wenn man vorsichtig is. hätte mir nicht zum ersten mal einen logd server zerstört.

Autor:  Kevz [ Sa 16 Dez, 2006 22:17 ]
Betreff des Beitrags: 

Warst dir aber noch oben ziemlich sicher, dass es von nöten ist. ;)
Dennoch zerstört man sich nicht durch Kommentar Blöcke nen ganzen Server, sondern durch leichtfälltigkeit und unwissenheit im bereich der PHP/MySQL Programmierung.

Autor:  the_Cr0w [ Sa 16 Dez, 2006 22:27 ]
Betreff des Beitrags: 

oben war ich mir nicht sicherer als jetzt

is mir klar, dass das durch ein kommentar nicht geht. aber ich wollte sagen, dass da eher etwas vorsichtiger bin.

Autor:  The Grinch [ So 30 Jan, 2011 19:39 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

Funktioniert die Rasse auch in der 0.9.7 Version?

Autor:  Jack [ So 30 Jan, 2011 19:53 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

Ja. Aber nicht auf die Art und weiße wie hier ;) Schau in der newday.php und common.php wie in der 0.97 die Rassen defniert sind

Autor:  MrEgo [ So 30 Jan, 2011 20:12 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

Jack hat geschrieben:
Ja. Aber nicht auf die Art und weiße wie hier ;) Schau in der newday.php und common.php wie in der 0.97 die Rassen defniert sind


Die Module von der Dragonprime Edition also 1.x.x dürfen nicht für die 097er genutzt werden! Da beide Editionen unter verschiedenen Lizenzen veröffentlicht wurden. Dazu kommt, dass die Sachen nicht kompatibel sind, da der Code zwar ähnelt, aber an vielen Stellen doch unterschiedlich ist. Die Dragonprime Edition ist Modular aufgebaut, es sind für den normal Betrieb keinerlei Änderungen am Hauptprogramm nötig. Sprich, wenn man was installieren möchte, macht man das bei der Version nur über die Grotte, ein einbauen wie in der 097er, dass man diverse Sachen ändern muss, zB. Sql Tabellen anlegen entfällt total. Da ich beide Versionen am laufen habe, kann ich sagen, dass jede Version seine Vor- und Nachteile hat :D

Autor:  Jack [ So 30 Jan, 2011 20:35 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

Die Rasse *Vampir* Kann man dennoch einbauen in der 0.97 wenn man den Code kompeltt selbst schreibt ;)

Autor:  MrEgo [ So 30 Jan, 2011 21:21 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

hehe, viel spaß dabei^^

Autor:  Jack [ So 30 Jan, 2011 21:42 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

In der 0.97 ist eine neue Rasse einfügen doch einfach :?

Autor:  MrEgo [ Mo 31 Jan, 2011 11:40 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

Naja, wenn man sich auf Standart Konzentriert dann schon, ich denke aber mal, dass er genau das nicht möchte, sondern eher Rassen, die mit anderen Agieren und Reagieren, z.B. dass der Vampir von anderen User Blutsaugen kann und Todesengel andere töten können etc. und das ist aus eigener Erfahrung nicht wirklich einfach, ich selbst programmiere grade solche Rassen allerdings für die 1.1.2 bin noch nicht fertig mit dem Vampir und das Script ist jetzt schon 1500 Zeilen lang. :D

Autor:  Jack [ Mo 31 Jan, 2011 14:58 ]
Betreff des Beitrags:  Re: LotGD 1.1.0 - Rasse - Vampir

ja ok :baeh:

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/