anpera.net
http://anpera.homeip.net/phpbb3/

lotgd Dragonslayer Edition V3
http://anpera.homeip.net/phpbb3/viewtopic.php?f=43&t=4865
Seite 20 von 22

Autor:  Jack [ So 20 Feb, 2011 15:09 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Für die SOnderzeichen

HTMLEntities

mit HtmlSpecialChar ersetzten

Und wie meinste, die Farben gehen nicht? Im Farbeditor muss man irgendwie was von wegen "CSS schreiben" drücken, dann gehen die Farben

Edit: Jedenfalls wenn ich von der 2.5er ausgehe. Da ich die V3 nicht habe

Autor:  Elouar [ So 20 Feb, 2011 15:44 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Und wo da ganze ersetzen ? ;)

Ich habe im Augenblick die Standardfarben drinenn, keine Sonderzeichen etc. und der `- Farbcode funzt standardmäßig nicht ^^ Und as ich wenn neue Farben vorhanden erst die CSS schreiben muss weiß ich ;)

Autor:  Linus [ So 20 Feb, 2011 21:44 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Elouar hat geschrieben:
Und wo da ganze ersetzen ? ;)

Überall, in allen php-Dateien, kannst du die Funktion HTMLEntities() durch HTMLSpecialChars() ersetzen.

Autor:  sheepy [ Sa 26 Feb, 2011 01:05 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Auric hat geschrieben:
ja, man muss nur das <input>-Feld durch eine <textarea> ersetzen.


Ich habe das so gemacht bei mir.

PHP:
output("<form action=\"".htmlspecialchars($REQUEST_URI)."\" method='POST'>`@$message`n
<textarea class='input' name='insertcommentary[$section]' rows='5' cols='80' maxlength='".($max_length-$tll)."'></textarea ",true);
if($session['user']['prefs']['preview']) {
output(' id="comin" onkeyup="com_prev(',true);
rawoutput('\''.addslashes($session['user']['name']).'\', ');
output('\''.$session['user']['prefs']['commentemotecolor'].'\', \''.$session['user']['prefs']['commenttalkcolor'].'\', ');
output('\''.$talkline.'\', '.getsetting('maxcolors',10));
output(');this.focus()"',true);
}

output("><br>
<input type='hidden' name='talkline' value='$talkline'>
<input type='submit' class='button' value='Hinzufügen'>`n`0`n</form>",true);

addnav("",$REQUEST_URI);

}


allerdigns funktioniert nun die chatvorschau nicht mehr. habe ich dort irgendwo einend enkfehler ? liebe grüße

Autor:  Jack [ Sa 26 Feb, 2011 11:16 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Bin mir nicht sicher.. Muss die Chatvorschau nicht in das öffnende Tag der Textarea? also mach es mal ungefähr so (aber ungetestet!)

$this->bbcode_second_pass_code('', 'output("<form action=\"".htmlspecialchars($REQUEST_URI)."\" method='POST'>`@$message`n
<textarea class='input' name='insertcommentary[$section]' rows='5' cols='80' maxlength='".($max_length-$tll)."",true);
if($session['user']['prefs']['preview']) {
output(' id="comin" onkeyup="com_prev(',true);
rawoutput('\''.addslashes($session['user']['name']).'\', ');
output('\''.$session['user']['prefs']['commentemotecolor'].'\', \''.$session['user']['prefs']['commenttalkcolor'].'\', ');
output('\''.$talkline.'\', '.getsetting('maxcolors',10));
output(');this.focus()"',true);
}

output("'></textarea><br>
<input type='hidden' name='talkline' value='$talkline'>
<input type='submit' class='button' value='Hinzufügen'>`n`0`n</form>",true);

addnav("",$REQUEST_URI);

}')

Autor:  Elouar [ So 27 Feb, 2011 10:27 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Jack hat recht du schließt die <textarea> zu früh wieder. Das Problem mit der Chatvorschau liegt am rot eingefärbten von mir ;D Einfach rausnehem, dann sollte es gehen. Maxlength ist bei einer textarea doch überflüssig.

<textarea class='input' name='insertcommentary[$section]' rows='5' cols='80' maxlength='".($max_length-$tll)."",true);

Autor:  Arwen Anouk [ Fr 15 Apr, 2011 20:45 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Hallo,

vielleicht eine blöde Frage aber welches ist denn die aktuelle Version?

jenu2_skins_dsv3.zip
Warcraft Skins.zip
Schloss_mit_Kompass.zip
medieval_skin_dsv3.zip

bin da verwirrt. Kann mir jemand helfen?

Autor:  Jack [ Fr 15 Apr, 2011 20:48 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Weder noch :lol:

lotgd_ds_edition_v2.5.zip

das ist das logd

Die V3 gibt es nicht mehr zum download

Autor:  Arwen Anouk [ Fr 15 Apr, 2011 23:24 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Achso, schade. Danke für die Info :)

Autor:  Finstergold [ Mi 15 Jun, 2011 20:03 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Jack hat geschrieben:
Für die SOnderzeichen

HTMLEntities

mit HtmlSpecialChar ersetzten

Und wie meinste, die Farben gehen nicht? Im Farbeditor muss man irgendwie was von wegen "CSS schreiben" drücken, dann gehen die Farben

Edit: Jedenfalls wenn ich von der 2.5er ausgehe. Da ich die V3 nicht habe




Das hab ich hingekriegt, so endlich XD
Nur leider aktualisieren sich nicht im Profil, wo man als Spieler anwählen kann, welche Farbe z. B. für gesagtes genommen wird, nicht die Auswahl, also das die neuen Farben hinzukommen.
Wer will mich glücklich machen und gibt mir nen Tipp, wo ich suchen soll?

Autor:  Jack [ Fr 17 Jun, 2011 10:07 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Da ich nicht weiß wie es im Profil aussieht in der DS.. Einfach die Farben im Profil mit dazumachen in der entsprechenden php?

Autor:  Donnind [ Fr 17 Jun, 2011 22:16 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Geht bei der Version meines Wissens nicht..Die Farben sind da fest im Cache. Aber man kann einfach beim Css-Schreiben ein appoencode(true,true) einbauen, dürfte es gehen. Das erste true is fürs Neuladen zuständig.

Ich hab eher das Problem mit der /X Funktion.
In der commentary.lib hast du ja
PHP:
else{
$symbol = 0;
if(substr($cm['comment'],0,4)=='/msg') {
$ret .= '`7'.str_replace($bad_color[0],$bad_color[1],HTMLspecialchars(substr($cm['comment'],4)))
.'`0';


nun möcht ich die funktion so haben, dass ich n Symbol dazu baue, also dass im Grunde statt des Usernamens n Icon is, das zur Bio führt. Ich hab's probiert, indem ich die Funktion hier oben nachgemacht hab, nur eben mit nem /X. in der commentary.lib und chat.lib, aber ich versteh nich, wie ich den Rest machen soll..also das Ersetzen des Namens.

Autor:  Bathory [ Fr 29 Jul, 2011 17:48 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Finstergold hat geschrieben:
Das hab ich hingekriegt, so endlich XD
Nur leider aktualisieren sich nicht im Profil, wo man als Spieler anwählen kann, welche Farbe z. B. für gesagtes genommen wird, nicht die Auswahl, also das die neuen Farben hinzukommen.
Wer will mich glücklich machen und gibt mir nen Tipp, wo ich suchen soll?


PHP:
Cache::delete(Cache::CACHE_TYPE_HDD|Cache::CACHE_TYPE_MEMORY , 'appoencode_allowed');


In der su_colors.php kommt folgendes 6 mal vor:
PHP:
Cache::delete(Cache::CACHE_TYPE_HDD|Cache::CACHE_TYPE_MEMORY , 'appoencode');


Ich würde das obige immer drunter schreiben, da vergessen wurde, dass es 2 Caches mit appoencode infos gibt.

Autor:  DragonWarrior [ Do 05 Apr, 2012 04:54 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Ich wollte nach Jahren mal wieder ein eigenes LoGD anfangen und ich verstehe plötzlich nichts mehr :D Damals noch mit der anpera Version, aber diese gibt mir heute Fehler. Ebenfalls die Dragonslayer Version 2.5 :/

Ich bekomme folgenden Fehlercode:

Deprecated: Function set_magic_quotes_runtime() is deprecated in /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php on line 17

Deprecated: Function session_register() is deprecated in /www/htdocs/w00e4dbb/lotgd/common.php on line 55

Warning: session_register() [function.session-register]: Cannot send session cache limiter - headers already sent (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/common.php on line 55

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/common.php on line 113

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/common.php on line 130
Don't Panic!
Soeben ist durch eine äußerst unwahrscheinliche Dimensionslücke weit draußen in den unerforschten Einöden eines total aus der Mode gekommenen Ausläufers des westlichen Spiralarms der Galaxis ein Datenbankfehler im Innenleben dieses Servers aufgetreten.
Bitte kopiere den untenstehenden Fehlertext und teile ihn der Administration per Anfrage mit! Du solltest auch beschreiben, was du unmittelbar davor getan / angeklickt hast.
Danke für dein Verständnis!
Hier kommt die Meldung:

Adresse: /lotgd/index.php?

INSERT INTO syslog
(date,actor,target,message)
VALUES (NOW(),0,0,"`&DB-Fehler: `^<i>Adresse: /lotgd/index.php?</i>
<pre>SELECT * FROM appoencode WHERE active=&quot;1&quot;</pre>
<b>1146:</b> Table \'d013bfbc.appoencode\' doesn\'t exist")

1146: Table 'd013bfbc.syslog' doesn't exist

Um weiterspielen zu können, sollte ein Klick auf den Zurück-Button deines Browsers ausreichen. Falls nicht, schließe das Browserfenster und rufe die Adresse neu auf. Schreibe dann von der Startseite aus eine Anfrage.


Was mach ich falsch? Das ist sowohl auf der Anpera als auch auf der DS Version. Oder habe ich irgendwas in den letzten Jahren verpasst, was mir das ausführen verhindert und ich irgendwas im Code ändern muss? Die neue 1.1.2er Version läuft auf einer anderen Datenbank wie geschmiert (nur leider auf Englisch und das Translator-Tool will nicht <.<)

Autor:  Harthas [ Do 05 Apr, 2012 09:48 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Am einfachsten wäre es für dich, im error_reporting deprecated errors nicht mehr anzeigen zu lassen.
http://ch2.php.net/manual/en/function.error-reporting.php

Zusätzlich meckert die DS-Version da rum, dass die Tabelle appoencode nicht in der Datenbank "d013bfbc" zu finden ist. Hast du den SQL-Import ausgeführt und die korrekte Datenbank angegeben?

Autor:  DragonWarrior [ Do 05 Apr, 2012 13:23 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Harthas hat geschrieben:
Am einfachsten wäre es für dich, im error_reporting deprecated errors nicht mehr anzeigen zu lassen.
http://ch2.php.net/manual/en/function.error-reporting.php

Zusätzlich meckert die DS-Version da rum, dass die Tabelle appoencode nicht in der Datenbank "d013bfbc" zu finden ist. Hast du den SQL-Import ausgeführt und die korrekte Datenbank angegeben?


Erstmal Danke für die Hilfe :wink:

Also meines Wissens nach, hab ich die SQL Datei in die Datenbank "d013bfbc" importiert und auch dort die richtige Datenbank gepackt :/ Ich schau sicherheitshalber nochmal nach.

Edit:

Aaaah! :D Ich musste einfach nochmal neu installieren, hatte wahrscheinlich einen Fehler in der Datenbank. So.. jetzt funktioniert schonmal das Spiel hab aber immer noch so manche Fehlermeldung oberhalb.

Deprecated: Function set_magic_quotes_runtime() is deprecated in /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php on line 17

Deprecated: Function session_register() is deprecated in /www/htdocs/w00e4dbb/lotgd/common.php on line 55

Warning: session_register() [function.session-register]: Cannot send session cache limiter - headers already sent (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/common.php on line 55

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/common.php on line 113

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/common.php on line 136

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/common.php on line 228


Wie ich sowas nicht mehr anzeigen lasse, ist mir grad nicht geläufig.. sorry :(

Edit 2:

Merke grade, ich kann mich gar nicht einloggen.. :?

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00e4dbb/lotgd/lib/db.lib.php:17) in /www/htdocs/w00e4dbb/lotgd/lib/nav.lib.php on line 211
newday.phpRedirected to index.php from login.php. Redirected to news.php from login.php. Redirected to newday.php from news.php.


Ich werd noch wahnsinnig :D Gibt es denn keine deutsche Version mehr mit Installer? Die Versionen haben früher immer funktioniert, ohne Fehler.

Autor:  Harthas [ Do 05 Apr, 2012 17:08 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Suche im Code der Dragonslayer-Version nach der Funktion error_reporting (Wird wohl irgendwo irgendwie aufgerufen). Dort solltest du ein "^E_DEPRECATED" anhängen. Wenns nicht gleich funktioniert, schau in der php.net-Dokumentation nach.

Autor:  DragonWarrior [ Fr 06 Apr, 2012 15:07 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

Auf jeden Fall danke für deine Hilfe. Ich lass es lieber :D Da ich kein gutes Verständniss in PHP und MySQL hab (ich kann leider nur die Basics) und auch nicht jede Datei nochmal einzeln durchgehen will (Notepad++ hat nämlich keinen Eintrag gefunden, der auch nur so ähnlich war).

Warte ich halt auf eine übersetzte Fassung mit Installer :D Da der Translation Wizard von 1.1.2 mir genauso Probleme macht und nur bei Lust und Laune mal funktioniert :/

Autor:  Chris [ So 30 Sep, 2012 22:56 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

In welcher Tabelle wird denn geregelt, wer momentan Fürst ist?
Ich hatte nun schon zweimal den Fall, dass ein gewählter Fürst seine Funktionen derartig missbraucht hat, dass ich am liebsten das Fürstenamt entziehen wollte. Leider weiß ich aber nicht, was ich dazu alles machen muss um z. B. einen Adminnick für die Rest der Amtszeit als Fürst einzusetzen.

Vielen Dank! :)

Chris

Autor:  Bathory [ So 30 Sep, 2012 23:18 ]
Betreff des Beitrags:  Re: lotgd Dragonslayer Edition V3

in der settings-tabelle gibt es einen fürsten-eintrag :D

Seite 20 von 22 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/