anpera.net

anpera.net

experimental server @home
Aktuelle Zeit: Sa 19 Sep, 2020 04:48

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 471 Beiträge ]  Gehe zu Seite Vorherige  1 ... 6, 7, 8, 9, 10, 11, 12 ... 24  Nächste
Autor Nachricht
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 01:58 
Offline
Freak
Freak
Benutzeravatar

Registriert: Di 11 Okt, 2005 18:11
Beiträge: 680
Wohnort: Wohnzimmer
Geschlecht: Männlich
LoGD: www.omega-grotte.de
MySql hat geschrieben:
du hast die 1 beim schliessen des INSERT's vergessen ;)

[php]und schüttet ein.', 1)";[/php]


ah lol...jetzt seh ich die 1 auch...ist mir garnicht aufgefallen.. :?
wie peinlich..jedenfalls danke für deine hilfe :D

_________________
Die Frage lautet: Herr? Bist du das Göttliche?
Daraufhin meint er nur: Ich bin es, aber warum fragst du?

Mein Game zur Zeit Offline...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 10:11 
Offline
Held
Held
Benutzeravatar

Registriert: Mi 09 Aug, 2006 09:29
Beiträge: 267
Geschlecht: Männlich
Naria hat geschrieben:
Es liegt an der Funktion HTMLEntities, die in der Editierfunktion gebraucht wird:

Suche in der editchat.php:

[php]$textinhalt=HTMLEntities("$_POST[textinhalt]");[/php]

Ersetze mit:

[php] $textinhalt= htmlspecialchars(strip_tags(trim($_POST['textinhalt'])));
$textinhalt= str_replace("&","&",$textinhalt);[/php]



Ich habe jetzt alles so geändert, jetzt wird der Editbutton garnicht mehr angezeigt vor den Posts?! :???:


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 11:59 
Offline
Freak
Freak
Benutzeravatar

Registriert: Di 01 Mai, 2007 13:57
Beiträge: 1634
Wohnort: Dortmund.
Geschlecht: Männlich
LoGD: Lokal.
Skype: josh.hoiul
[php]$textinhalt= htmlspecialchars(strip_tags(trim("$_POST[textinhalt]")));
$textinhalt= str_replace("&","&",$textinhalt);[/php]

Und nu?

_________________
Never change a running system. Bullshit! ;)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 12:33 
Offline
Held
Held
Benutzeravatar

Registriert: Mo 05 Mär, 2007 22:17
Beiträge: 270
Das liegt aber nicht an dieser Veränderung, sondern sollte eigentlich an deiner viewcommentary liegen... das der Link auf die Datei nicht richtig verarbeitet wird...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 14:03 
Offline
Held
Held
Benutzeravatar

Registriert: Mi 09 Aug, 2006 09:29
Beiträge: 267
Geschlecht: Männlich
Geht trotzdem nicht...

Was kann ich da jetzt machen?


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 14:54 
Offline
Held
Held
Benutzeravatar

Registriert: Mo 05 Mär, 2007 22:17
Beiträge: 270
Programmieren ^^ ganz einfach

Such mal in der commentary.php danach:
[php]
// Letzten Post Löschen [Added by Auric]
$dellink="chat_delete.php?section=".$this->section."&return=".rawurlencode($REQUEST_URI);
rawoutput(" <a href=\"".$dellink."\" style=\"color: red;\">Letzten Post löschen</a>");
addnav('',$dellink); [/php]

danach musst du den entsprechenden Link einfügen... den hast du doch noch von der Editfunktion, die mal funktioniert hat... ansonsten kannst du dir den zusammenbasteln...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 19:31 
Offline
Held
Held
Benutzeravatar

Registriert: Mi 09 Aug, 2006 09:29
Beiträge: 267
Geschlecht: Männlich
Hatte den Link von der Editfunktion gerade dahinter gebaut, klappt trotzdem nicht, der zeigt mir den Button nicht mehr an...

Wenn vom System was gepostet wird, zB wenn jemand ein Ale spendet oder einer einen Schlüssel vergibt, dann steht es so da-->

/me vergibt einen Schlüssel an XX

Also immer mit dem /me


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 20:05 
Offline
Marquis Pherae
Marquis Pherae

Registriert: Mi 09 Feb, 2005 16:01
Beiträge: 3922
Wohnort: Basel
Geschlecht: Männlich
Rantanplan hat geschrieben:
Hatte den Link von der Editfunktion gerade dahinter gebaut, klappt trotzdem nicht, der zeigt mir den Button nicht mehr an...

Wenn vom System was gepostet wird, zB wenn jemand ein Ale spendet oder einer einen Schlüssel vergibt, dann steht es so da-->

/me vergibt einen Schlüssel an XX

Also immer mit dem /me


Schau doch mal auf Seite 3 nach... Quall hatte sogar 2 Seiten vorher die gleiche Frage gepostet.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 20:25 
Offline
Freak
Freak
Benutzeravatar

Registriert: Di 01 Mai, 2007 13:57
Beiträge: 1634
Wohnort: Dortmund.
Geschlecht: Männlich
LoGD: Lokal.
Skype: josh.hoiul
Die antwort gab es auch 2 seiten vorher ;)

Vor dem Schlissen der UPDATE btw. INSERT ein ', 1^^

_________________
Never change a running system. Bullshit! ;)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 20:37 
Offline
Held
Held
Benutzeravatar

Registriert: Mi 09 Aug, 2006 09:29
Beiträge: 267
Geschlecht: Männlich
$sql = "INSERT INTO commentary (postdate,section,author,comment,emote) VALUES (now(),'inn',".$session[user][acctid].",'spendiert die nächsten `^$amt`& Ale!',1";


$sql = "INSERT INTO commentary (postdate,section,author,comment,emote) VALUES (now(),'beggar',".$session[user][acctid].",\"hat `^$goldsumme Goldstücke`& auf dem Spenden-Stein hinterlegt!\",1";


So in etwa? Aber der Fehler is immernoch da... :(


EDIT: ALles klar, war ganz einfach :P Hab es schon...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 20:44 
Offline
Marquis Pherae
Marquis Pherae

Registriert: Mi 09 Feb, 2005 16:01
Beiträge: 3922
Wohnort: Basel
Geschlecht: Männlich
Rantanplan hat geschrieben:
$sql = "INSERT INTO commentary (postdate,section,author,comment,emote) VALUES (now(),'inn',".$session[user][acctid].",'spendiert die nächsten `^$amt`& Ale!',1";


$sql = "INSERT INTO commentary (postdate,section,author,comment,emote) VALUES (now(),'beggar',".$session[user][acctid].","hat `^$goldsumme Goldstücke`& auf dem Spenden-Stein hinterlegt!",1";


So in etwa? Aber der Fehler is immernoch da... :(


Um Seite 3 gibts auch n' Script, das alle alte Kommentare in neue verwandelt. Etwas lesen kann man wohl verlangen, oder?!

PS: Du musst die Klammer schon wieder zumachen:

[php]$sql = "INSERT INTO commentary (postdate,section,author,comment,emote) VALUES (now(),'inn',".$session[user][acctid].",'spendiert die nächsten `^$amt`& Ale!',1)";


$sql = "INSERT INTO commentary (postdate,section,author,comment,emote) VALUES (now(),'beggar',".$session[user][acctid].","hat `^$goldsumme Goldstücke`& auf dem Spenden-Stein hinterlegt!",1)";[/php]


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: So 12 Aug, 2007 20:58 
Offline
Held
Held
Benutzeravatar

Registriert: Mi 09 Aug, 2006 09:29
Beiträge: 267
Geschlecht: Männlich
Tut mir Leid, irgendwann übersieht man eben Kleinigkeiten, ausserdem habe ich ja gerade editiert das ich es schon geändert habe...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Hallo
BeitragVerfasst: Do 16 Aug, 2007 14:41 
Offline
User
User

Registriert: Do 19 Apr, 2007 18:46
Beiträge: 19
Ich finde den Mysql befehl nicht mehr um die tabelle zu erstellen wie war der noch mal? commentary
Mfg Xaxas(http://www.eythgim.ch.vu)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: Do 16 Aug, 2007 15:14 
Offline
Freak
Freak
Benutzeravatar

Registriert: Di 01 Mai, 2007 13:57
Beiträge: 1634
Wohnort: Dortmund.
Geschlecht: Männlich
LoGD: Lokal.
Skype: josh.hoiul
o_o

Eliwood hat geschrieben:
ALTER TABLE `commentary` ADD `emote` tinyint(3) unsigned NOT NULL default '0';

_________________
Never change a running system. Bullshit! ;)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Hallo
BeitragVerfasst: Do 16 Aug, 2007 15:33 
Offline
User
User

Registriert: Do 19 Apr, 2007 18:46
Beiträge: 19
Ich meine den Befehl um die Tabeele zu erstellen CREATE TABLE aber für Hilfe wäre ich echt dankbar.
Mfg Xaxas


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: Do 16 Aug, 2007 16:46 
Offline
Marquis Pherae
Marquis Pherae

Registriert: Mi 09 Feb, 2005 16:01
Beiträge: 3922
Wohnort: Basel
Geschlecht: Männlich
Wenn du die Tabelle "commentary" nicht hast, hast du eine inkompatible Version und kannst dieses Packet nicht einbauen.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: Do 16 Aug, 2007 16:47 
Offline
Freak
Freak
Benutzeravatar

Registriert: Di 01 Mai, 2007 13:57
Beiträge: 1634
Wohnort: Dortmund.
Geschlecht: Männlich
LoGD: Lokal.
Skype: josh.hoiul
Es wurde via MSN schon geholfen.
Er hatte die ' commentary ' tabelle ausversehen geloescht..

_________________
Never change a running system. Bullshit! ;)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: Di 21 Aug, 2007 20:31 
Offline
Meister
Meister
Benutzeravatar

Registriert: Fr 17 Aug, 2007 22:36
Beiträge: 367
Wohnort: In unergründlichen Höhlen
Geschlecht: Weiblich
LoGD: http://projekt-davorin.de/
o.O hab grad die version in meine common gebaut- sofort kam der fehler:


Warning: main(lib/commentary.php): failed to open stream: No such file or directory in /srv/www/web1/html/common.php on line 2044

Warning: main(): Failed opening 'lib/commentary.php' for inclusion (include_path='.:') in /srv/www/web1/html/common.php on line 2044

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/web1/html/common.php:2044) in /srv/www/web1/html/common.php on line 75

_________________
Mao?
Unsere Scripte verfassen wir in Beerware

PHP:
Davorin- Waldkämpfe klickern war gestern
;) Nu wird gequestet!
(Im Aufbau)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: Di 21 Aug, 2007 21:00 
Offline
Marquis Pherae
Marquis Pherae

Registriert: Mi 09 Feb, 2005 16:01
Beiträge: 3922
Wohnort: Basel
Geschlecht: Männlich
Die Datei gehört auch in den Ordner $LOGD_ROOT/lib... :roll:


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags:
BeitragVerfasst: Di 21 Aug, 2007 22:09 
Offline
Meister
Meister
Benutzeravatar

Registriert: Fr 17 Aug, 2007 22:36
Beiträge: 367
Wohnort: In unergründlichen Höhlen
Geschlecht: Weiblich
LoGD: http://projekt-davorin.de/
Fatal error: Cannot redeclare addcommentary() (previously declared in /srv/www/web1/html/common.php:1455) in /srv/www/web1/html/lib/commentary.php on line 1195

hab's brav verschoben ;)

_________________
Mao?
Unsere Scripte verfassen wir in Beerware

PHP:
Davorin- Waldkämpfe klickern war gestern
;) Nu wird gequestet!
(Im Aufbau)


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 471 Beiträge ]  Gehe zu Seite Vorherige  1 ... 6, 7, 8, 9, 10, 11, 12 ... 24  Nächste

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen
Du darfst keine Antworten zu Themen in diesem Forum erstellen
Du darfst deine Beiträge in diesem Forum nicht ändern
Du darfst deine Beiträge in diesem Forum nicht löschen
Du darfst keine Dateianhänge in diesem Forum erstellen

Suche nach:
Gehe zu:  
cron
POWERED_BY
Deutsche Übersetzung durch phpBB.de
anpera.net - Impressum