anpera.net
http://anpera.homeip.net/phpbb3/

Leeres Waldereignis
http://anpera.homeip.net/phpbb3/viewtopic.php?f=34&t=5535
Seite 1 von 1

Autor:  Yoichiro [ So 30 Jun, 2013 18:19 ]
Betreff des Beitrags:  Leeres Waldereignis

Huhu,

ich hab jetzt den Fall, dass ein leeres Waldereignis aufgetaucht ist. Navigation ist komplett da, nur steht halt in der Mitte "Etwas Besonderes" und mehr nicht. Ich hab hier schon gesucht und fand Hinweise auf die wege.php und den Waldspecialeditor. Da ich beides nicht habe, kanns daran auch nicht liegen. Hilfe :(

Hier auch noch ein Screenshot

Bild

Autor:  Shaddar [ So 30 Jun, 2013 18:41 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

Aus deinem Screenshot geht leider nicht hervor welches Level du bist, aber als ich damals ein ähnliches "Problem" hatte lag es an dem Special fightmaster.php welches dich direkt in den Wald zurück schickt wenn du eben schon Level 15 bist. Wäre mein spontaner Einfall dazu.

Autor:  Yoichiro [ So 30 Jun, 2013 18:54 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

Der Spieler bei dem es jetzt schon 2 Mal passiert ist, ist erst Level 7. Ich versteh nicht wo der Fehler herkommt :(

Autor:  Shaddar [ So 30 Jun, 2013 18:56 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

Da ich in deiner Source nicht auf die Specials zugreifen kann, kann ich dir dann leider auch nicht weiterhelfen.

Autor:  Yoichiro [ So 30 Jun, 2013 19:00 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

Ich hab die Specials jetzt alle geöffnet.

Danke für deine Hilfe

Autor:  anpera [ Mo 01 Jul, 2013 23:18 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

Ich habe da einen Verdacht:
Du hast eine sehr sehr alte forest.php, die bei Waldereignissen, die mit $_GET statt mit $HTTP_GET_VARS arbeiten, nicht abgefangene Fälle provozieren kann.

Wenn Spieler auf ein besonderes Ereignis treffen, ist die forest.php mit ...op=search oder ganz ohne op aufgerufen worden. Bevor das besondere Ereignis gestartet wird, setzt die forest.php $HTTP_GET_VARS['op'] auf "". Der Fall $HTTP_GET_VARS['op'] == "search" kommt also in Specials nie vor und muss nicht abgefangen werden.

Ereignisse, die auf $_GET['op'] abfragen, MÜSSEN bei dir aber auch den Fall $_GET['op'] == "search" berücksichtigen, weil deine forest.php eben nur $HTTP_GET_VARS['op'] auf "" setzt, nicht aber $_GET['op']!

Dein Special demon.php ist z.B. davon betroffen. Der Fall $_GET['op'] == "search" ist nicht abgefangen, eine Default-Schleife gibt es nicht - folglich bleibt das Ereignis leer, wenn es mit "...op=search" gefunden wird.


Die einfachere, aber nicht unbedingt zu empfehlende Lösung wäre es, alle Waldereignisse auf $HTTP_GET_VARS umzuschreiben, oder den Fall $_GET['op'] == "search" überall mit einzubauen, wo auf $_GET['op'] == "" abgefragt wird.

Die bessere Lösung wäre es, die forest.php so umzuschreiben, dass sie sowohl Waldereignisse mit $_GET wie auch mit $HTTP_GET_VARS korrekt (nämlich ohne den Fall "search") versorgen kann.
Die forest.php von hier beherrscht diesen Trick und kann dir vielleicht als Hilfestellung dienen.

Die beste Lösung wäre es natürlich, komplett auf $_GET umzusatteln. ;)

Autor:  Yoichiro [ Di 02 Jul, 2013 14:03 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

Ich sehe viel Arbeit auf mich zukommen xD

Danke schön :)

Autor:  Shaddar [ Di 02 Jul, 2013 18:58 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

Ach das kommt ganz auf deinen Editor drauf an würde ich sagen ^^
Ich arbeite z.B. seit Anfang an mit Notepad++ und die dateiübergreifende Suche und Ersetzen Funktion ist sehr hilfreich, dann ist das ne Sache von einer Minute :D

Autor:  Yoichiro [ Di 02 Jul, 2013 23:36 ]
Betreff des Beitrags:  Re: Leeres Waldereignis

den nutz ich ja auch xD
Aber auf die Idee bin ich noch nicht gekommen :D

Danke :)

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/