anpera.net
http://anpera.homeip.net/phpbb3/

Field 'badguy' doesn't have a default value
http://anpera.homeip.net/phpbb3/viewtopic.php?f=34&t=5373
Seite 1 von 1

Autor:  aberlol [ Do 02 Feb, 2012 19:35 ]
Betreff des Beitrags:  Field 'badguy' doesn't have a default value

Also, Ich habe mir die Source von dieser Seite genommen und da war auch diese Sql Datei dabei
Wenn ich allerdings diese Sql Datei mit PHPMyAdmin ausführe bekomme ich immer diesen Fehler ins gesicht geschmissen


Fehler
SQL-Befehl:

#
# Daten für Tabelle `accounts`
#
INSERT INTO accounts( login, name,
PASSWORD , superuser, laston ) VALUES (

"ADMIN",
"ADMIN",
"7cc93b8005c402adcca36d68cd6a573c",
3,
NOW( )
);

MySQL meldet:

#1364 - Field 'badguy' doesn't have a default value

Installiert wird alles Local via XAMPP
Die Suche hab ich auch bereits benutzt und Nicht wirklich eine lösung gefunden(vll falsch gesucht?)

Autor:  MySql [ Fr 03 Feb, 2012 01:07 ]
Betreff des Beitrags:  Re: Field 'badguy' doesn't have a default value

Erst einmal ein herzliches Willkommen im deutschen LotGD Programmierer Forum ANPERA. :-)

Ich kenne diesen Fehler nur im Zusammenhang mit Datenbankaktualisierungen. Dort wird der Fehler hervorgerufen, wenn das alte Schema der Datenbank (In diesem Fall unsere SQL-Datei) nicht mit dem Schema der neuen Datenbank harmoniert.

MySQL - Bug #38173 " Field doesn't have a default value " with row-based replication

Um den Fehler zu beheben solltest Du dem Feld einen Standardwert geben oder erlaube dem Feld das es 'Null' sein darf.

Liebe Grüße,
My.

Autor:  aberlol [ Fr 03 Feb, 2012 01:31 ]
Betreff des Beitrags:  Re: Field 'badguy' doesn't have a default value

Danke für das Wilkommen heißen :)
und es Hat geklappt :)
jetzt darf ich mich weiter durchwuseln^^

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/