anpera.net
http://anpera.homeip.net/phpbb3/

Installationsproblem
http://anpera.homeip.net/phpbb3/viewtopic.php?f=34&t=5333
Seite 1 von 1

Autor:  Abresha [ Fr 15 Apr, 2011 16:05 ]
Betreff des Beitrags:  Installationsproblem

Hallöchen allerseits

Wollte mir eben mal Version 0.9.7 aufm localhost installieren, bin aber schon in den Anfängen stecken geblieben.

Apache & SQL laufen, die sql-Datei ist importiert, die dbconnect.php erstellt.
Aussehen wie folgt:
PHP:
<?php
$DB_USER="Lizune"; //Database Username
$DB_PASS="geheim"; //Database Password
$DB_HOST="localhost"; //Database Hostname
$DB_NAME="neu"; //Database Databasename

if ($DB_USER.$DB_PASS.$DB_HOST.$DB_NAME == ""){
echo "You must edit the dbconnect.php file to set it up for your database.";
}
?>


Lizune hat selbstverständlich alle Rechte.


Laut Readme ("Once you have set up dbconnect.php, you can log in to your new site...") kann's jetzt losgehen - Pustekuchen.
Wenn ich localhost aufrufe kommt folgendes:


$this->bbcode_second_pass_code('', 'Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\PLATTE G\LOGD\Xampp\xampp\htdocs\dbwrapper.php on line 18
"To" translation combinations. Only one translation per output() or addnav() call will occur, so if you have multiple translations that have to occur on the same call, place them in to their own array as an element in the $replace array. This entire sub array will be replaced, and if any matches are found, further replacements will not be made. If you are replacing a single output() or addnav() call that uses variables in the middle, you will have to follow the above stated process for each piece of text between the variables. Example, output("MightyE rules`nOh yes he does`n"); output("MightyE is Awesome $i times a day, and Superawesome $j times a day."); you will need a replace array like this: $replace = array( "MightyE rules`nOh yes he does`n"=>"MightyE rulezors`nOh my yes`n" ,array( "MightyE is Awesome"=>"MightyE is Awesomezor" ,"times a day, and Superawesome"=>"timez a dayzor, and Superawesomezor" ,"times a day."=>"timez a dayzor." ) ); */ //output(output_array($session['user']['prefs'])); $language = $session['user']['prefs']['language']; if ($language=="") $language=$_COOKIE['language']; if ($language=="") $language=getsetting("defaultlanguage","en"); if (file_exists("translator_".$language.".php")){ require_once "translator_".$language.".php"; }else{ require_once "translator_en.php"; } function replacer($input,$replace){ $originput = $input; if (!is_array($replace)) return $input; while (list($s,$r)=each($replace)){ if (is_array($r)){ $input = str_replace(array_keys($r),array_values($r),$input); }else{ $input = str_replace($s,$r,$input); } if ($originput!=$input) return $input; } return $input; } ?>
Deprecated: Function session_register() is deprecated in C:\PLATTE G\LOGD\Xampp\xampp\htdocs\common.php on line 1715

Warning: session_register() [function.session-register]: Cannot send session cache limiter - headers already sent (output started at C:\PLATTE G\LOGD\Xampp\xampp\htdocs\dbwrapper.php:18) in C:\PLATTE G\LOGD\Xampp\xampp\htdocs\common.php on line 1715

Deprecated: Function split() is deprecated in C:\PLATTE G\LOGD\Xampp\xampp\htdocs\common.php on line 964

Fatal error: Call to undefined function translate() in C:\PLATTE G\LOGD\Xampp\xampp\htdocs\common.php on line 37')


Jetzt frag ich mich allerdings, ich hab außer die dbconnect ja alles im Original, wo kommt sowas dann her?

Und wie geht's wieder weg?

Hatte vorher die 1.1.2 Version ein paar Monate lokal & auch im Netz, wollte mal was neues austesten und leg mir nun aber die Karten.

Hoffe da kann mir jemand helfen x)

Ps. Hatte die Suchfunktion schon bemüht aber leider nichts hilfreiches gefunden, sollte es das Problem schonmal gegeben haben, bitte ich untertänigst, das zu entschuldigen :)

Autor:  anpera [ Fr 15 Apr, 2011 17:26 ]
Betreff des Beitrags:  Re: Installationsproblem

LoGD 0.9.7 ist uralt. Deine PHP-Version ist es offenbar nicht.

Da sind eventuell ein paar Einstellungen in der PHP.INI notwendig, um veraltete Befehle weiterhin zu unterstützen. Außerdem müsstest du zwingend folgenden Thread abarbeiten, um LoGD 0.9.7 mit PHP5 oder höher zum Laufen zu kriegen. Die Änderungen sind im Downloadpaket noch nicht enthalten.

- Klick -

Autor:  Abresha [ Fr 15 Apr, 2011 17:52 ]
Betreff des Beitrags:  Re: Installationsproblem

Vielen Dank für die Infos, aber bei soo vielen Änderugnen frag ich mich grade wirklich, ob es sich lohnt x)
Aber ich denk, ich werd's einfach mal testen (man hat ja sonst nichts zu tun 8))
Danke schonmal, hoffe das klappt dann alles :)

Autor:  Taikun14 [ Fr 15 Apr, 2011 17:56 ]
Betreff des Beitrags:  Re: Installationsproblem

Anders kriegst du es ja auf PHP 5.x.x nicht zum Laufen.

Alternativ kannst du deinen Lokalserver auf PHP 4 umstellen, wenn es möglich ist.

Autor:  Abresha [ Fr 15 Apr, 2011 19:04 ]
Betreff des Beitrags:  Re: Installationsproblem

Danach such' ich auch grade ... aber bei meiner Version von XAMPP 1.7.3 scheint das nicht möglich zu sein. Mhpf.

Nagut, merci beaucoup aber an alle :)

Autor:  Lori [ Do 28 Apr, 2011 11:27 ]
Betreff des Beitrags:  Re: Installationsproblem

Du kannst auch einen ältere Version von XAMPP runterladen udn installieren. Ich glaube mit 1.6.8 sollte das 0.9.7 LogD ohne Veränderungen funtkionieren.

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/