anpera.net

anpera.net

experimental server @home
Aktuelle Zeit: So 18 Aug, 2019 22:08

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 10 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Mo 15 Feb, 2010 22:12 
Offline
Newbie

Registriert: Fr 12 Feb, 2010 18:25
Beiträge: 5
Wohnort: Emmerzhausen
Geschlecht: Männlich
LoGD: Im moment Localhost :D
Hallo Leute,

habe mir mal LoGD runtergeladen weil ich mich gerne mit php beschäftige und auch gerne mal was dazulerne :)
PHP kann ich in den Grundkenntnissen, allerdings gibt es was, wo ich wirklich nciht weiter weiß.
JA, Ich habe die Suchfunktion benutzt, Beiträge gefunden aber wurde nicht schlau draus deswegen frage ich doch hier nochmal :)

Habe LoGD (local!) installiert, starte in meinen appache & mysql, alle sql tables sind installed und auch die datensätze sind geaddet.

Beim Login gebe ich dann:
User: ADMIN
PW: CHANGEME
ein und bekomme dann angezeigt "Fehler: Die Login-Daten snid fehlerhaft!".
Neue Benutzer erstellen funktioniert schonmal gar nicht. Da gebe ich alles passend ein und bekomme nach absenden der Daten nur noch ein leeres Formular anzeigt.

Bitte um Hilfe :)

LG
Tiedo


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Mo 15 Feb, 2010 22:25 
Offline
Freak
Freak

Registriert: So 29 Jan, 2006 09:41
Beiträge: 1927
Wohnort: Schweiz
Geschlecht: Männlich
Skype: louis.huppenbauer
Such doch bitte mal nach PHP5 Änderungen. Das sollte dein Problem dann erledigen.

http://anpera.homeip.net/phpbb3/viewtopic.php?f=25&t=2167
http://anpera.homeip.net/phpbb3/viewtopic.php?f=26&t=317&start=40

Ich habe inzwischen allerdings gemerkt, dass es gar nicht mehr so einfach ist, die Lösung zu finden. *g*
Könnte man dies ev. in die FAQ aufnehmen? Oder dort zumindest einen LotGD-Part einrichten?


Zuletzt geändert von Harthas am Mo 15 Feb, 2010 22:28, insgesamt 1-mal geändert.

Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Mo 15 Feb, 2010 22:26 
Offline
Held
Held

Registriert: Fr 17 Okt, 2008 20:06
Beiträge: 253
Geschlecht: Männlich
LoGD: off
Such mal gründlicher...

Mach mal alle Änderungen für PHP5

edit:Da war jemand schneller.. Mist :D

_________________
Wenn ihr mir sagt wie ich es als Datei hochlade, dann kann ich die Source hochladen die ihr wollt .D


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Di 16 Feb, 2010 21:10 
Offline
Newbie

Registriert: Fr 12 Feb, 2010 18:25
Beiträge: 5
Wohnort: Emmerzhausen
Geschlecht: Männlich
LoGD: Im moment Localhost :D
Ich hab alle Änderungen so überschrieben wie es in den Anleitungen steht.
Klappt immernoch nicht.
Kann mir jemand einen Tip geben?
Der Server ist bei mir Local sonst würde ich einen Link geben...


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Do 18 Feb, 2010 14:02 
Offline
Newbie

Registriert: Fr 12 Feb, 2010 18:25
Beiträge: 5
Wohnort: Emmerzhausen
Geschlecht: Männlich
LoGD: Im moment Localhost :D
/push :)


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Do 18 Feb, 2010 14:13 
Offline
Freak
Freak

Registriert: Mo 06 Sep, 2004 15:17
Beiträge: 3236
Geschlecht: Männlich
Ist es nach wie vor die selbige Fehlermeldung, oder?


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Do 18 Feb, 2010 14:13 
Offline
Marquis Pherae
Marquis Pherae

Registriert: Mi 09 Feb, 2005 16:01
Beiträge: 3921
Wohnort: Basel
Geschlecht: Männlich
Mir scheint, dass da eine weitere, grosse Änderung nirgends stand. Seit PHP 5.wasweissich ist die Einstellung register_long_array standardgemäss aus - als Vorbereitung für PHP 6, die das gar nicht mehr unterstützen wird.

Es gibt nun zwei Möglichkeiten: Entweder ersetzt man in *jeder* Datei $HTTP_GET_VARS mit $_GET, $HTTP_POST_VARS mit $_POST, $HTTP_SERVER_VARS mit $_SERVER, $HTTP_POST_FILES mit $_FILES (usw.) - oder man verwendet einen unschönen Hack, den man in den Kopf der dbwrapper.php setzen kann:

$this->bbcode_second_pass_code('', '$HTTP_GET_vARS = &$_GET;
$HTTP_POST_VARS = &$_POST;
// usw.')


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Do 18 Feb, 2010 17:41 
Offline
Newbie

Registriert: Fr 12 Feb, 2010 18:25
Beiträge: 5
Wohnort: Emmerzhausen
Geschlecht: Männlich
LoGD: Im moment Localhost :D
aaah danke damit klappts dann doch endlich :)

Also mehr oder weniger, werde weitergleitet und dann steht da keine wichtigen News blah blah aber kein Menü und nichts. Aber das hat ja nichts mehr mit dem Thema zu tun :)

Danke nochmals an alle!


//edit:

Habe nichts weiter verändert und bekomme jetzt nach Login immer eine komplett leere und weiße login.php angezeigt!?

Help :D


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Fr 19 Feb, 2010 18:44 
Offline
Marquis Pherae
Marquis Pherae

Registriert: Mi 09 Feb, 2005 16:01
Beiträge: 3921
Wohnort: Basel
Geschlecht: Männlich
Okay. Nächster Schritt. Ich ahne auch bereits, was den Fehler verursachen könnte.

In der common.php, Funktion page_footer, findest du eine Stelle, die in etwa so aussieht:

$this->bbcode_second_pass_code('', 'echo compress_out($output);')
Ändere diese Zeile in:
$this->bbcode_second_pass_code('', 'echo $output;')

Dann solltest du normal Spielen können. Dir wird weiterhin Fehlerausgaben auffallen, die dann endlich ausgegeben werden, und auf den Fehler hinweisen. Die könntest du dann hier posten - oder einfach ignorieren. compress_out() ist sowieso a) ein unschöner Hack und b) für localhost ziemlich unnötig.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Login Problem mit LoGD 0.9.7
BeitragVerfasst: Fr 19 Feb, 2010 19:20 
Offline
Newbie

Registriert: Fr 12 Feb, 2010 18:25
Beiträge: 5
Wohnort: Emmerzhausen
Geschlecht: Männlich
LoGD: Im moment Localhost :D
Danke für den Script habs mal geändert, allerdings bekomme ich nach login immernoch eine weiße login.php angezeigt


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 10 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen
Du darfst keine Antworten zu Themen in diesem Forum erstellen
Du darfst deine Beiträge in diesem Forum nicht ändern
Du darfst deine Beiträge in diesem Forum nicht löschen
Du darfst keine Dateianhänge in diesem Forum erstellen

Suche nach:
Gehe zu:  
cron
POWERED_BY
Deutsche Übersetzung durch phpBB.de
anpera.net - Impressum