anpera.net
http://anpera.homeip.net/phpbb3/

Problem mit dem Local Server
http://anpera.homeip.net/phpbb3/viewtopic.php?f=34&t=3488
Seite 1 von 2

Autor:  booN [ Do 22 Mär, 2007 16:44 ]
Betreff des Beitrags:  Problem mit dem Local Server

Laut meinem Browser
Zitat:
You must edit the dbconnect.php file to set it up for your database.
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\xampplite\htdocs\logd\dbwrapper.php on line 112

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in C:\xampplite\htdocs\logd\dbwrapper.php on line 73


hab ich irgendwas falsch gemacht XD
mein Englisch reicht gerade aus, um zu erkennen, das irgendein Zugriff verweigert wurde. Warscheinlich auf die datei dbwrapper. Dummerweise habe ich den User ODBC nicht mal angelegt, und auch im Xampp kann ich den net finden^^°°

Autor:  Harthas [ Do 22 Mär, 2007 16:49 ]
Betreff des Beitrags: 

Du musst die dbconnect.php editieren: Sprich, deine Datenbank-Daten einfügen ;-)

Autor:  booN [ Do 22 Mär, 2007 16:53 ]
Betreff des Beitrags: 

hab ich :shock:
Denk ich jedenfalls:
Code:
<?php
$DB_USER=""; //logd
$DB_PASS=""; //[Post ich jetzt net]
$DB_HOST=""; //localhost
$DB_NAME=""; //logd

if ($DB_USER.$DB_PASS.$DB_HOST.$DB_NAME == ""){
   echo "You must edit the dbconnect.php file to set it up for your database.";
}
?>

Autor:  Harthas [ Do 22 Mär, 2007 16:55 ]
Betreff des Beitrags: 

Nein *kopfschüttel* Hast du eben nicht ;-)

Die Daten müssen IN die Anführungs- und Schlusszeichen rein ;-)

BSP.:
[php]$DB_USER="logd"; // [/php]

Autor:  booN [ Do 22 Mär, 2007 17:01 ]
Betreff des Beitrags: 

:o ups....danke^^'

Es plappt!!!! *freu*^^'''
Sieht zwar ziemlich ...äh...gammelig aus, aber das ist schonma ein anfang :)

edit:
Ich hab schon bei suchen gesucht (wie clever^^) aber nix dazu gefunden, aber ich weis auch net so recht, ob das hier rein gehört:
Mein XAMPP will nicht mehr starten. Ich gehe auf XAMPP Control Panel, klicke überall auf star (Ausser bei FileZilla) aber nur MySql startet. Unten in diesem Textfeld steht zwar, dass Apache bzw. Mercury startet, aber es tut sich nichts und man kann auch nicht auf /localhost/ zugreifen :cry:

HAT ALLES GEKLAPPT, Danke Harthas

Autor:  Setsna [ So 08 Apr, 2007 13:08 ]
Betreff des Beitrags: 

Zitat:
edit:
Ich hab schon bei suchen gesucht (wie clever^^) aber nix dazu gefunden, aber ich weis auch net so recht, ob das hier rein gehört:
Mein XAMPP will nicht mehr starten. Ich gehe auf XAMPP Control Panel, klicke überall auf star (Ausser bei FileZilla) aber nur MySql startet. Unten in diesem Textfeld steht zwar, dass Apache bzw. Mercury startet, aber es tut sich nichts und man kann auch nicht auf /localhost/ zugreifen HEUL


Ist das nun noch aktuell? Nunja, ich Antworte einfach mal ;-)
Wenn Apache nicht starten will dann mach eventuell mal Skype aus (Falls du es denn laufen hast) da das netterweise auch Port 80 nutzt. Wenn Apache erstmal rennt, kannst du es dann wieder anmachen - Ansonsten einfach mal prüfen ob sonst noch irgendwelche Programme diesen Port behindern könnten

Autor:  rumpel [ So 08 Apr, 2007 22:49 ]
Betreff des Beitrags: 

booN hat geschrieben:
hab ich :shock:
Denk ich jedenfalls:
Code:
<?php
$DB_USER=""; //logd
$DB_PASS=""; //[Post ich jetzt net]
$DB_HOST=""; //localhost
$DB_NAME=""; //logd

if ($DB_USER.$DB_PASS.$DB_HOST.$DB_NAME == ""){
   echo "You must edit the dbconnect.php file to set it up for your database.";
}
?>


Das erinnert mich an meine erste Installation von logd, da hab ich das damals auch neben dem // eingetragen xD

Autor:  -DoM [ Mo 09 Apr, 2007 10:47 ]
Betreff des Beitrags: 

Herr Gott im Himmel, schenke uns einen Installer....*fg*

Autor:  Auric [ Mo 09 Apr, 2007 12:39 ]
Betreff des Beitrags: 

Wäre echt mal ganz sinnvoll.. das noch nier einer auf die idee gekommen ist?

Autor:  Kevz [ Mo 09 Apr, 2007 14:11 ]
Betreff des Beitrags: 

Och auf die Idee gekommen schon, auch auf die Umsetzung - nur nicht viel Interesse gehabt es weiter umzusetzen. ;)

Autor:  Nightborn [ Mo 09 Apr, 2007 14:59 ]
Betreff des Beitrags: 

-DoM hat geschrieben:
Herr Gott im Himmel, schenke uns einen Installer....*fg*


bitteschön: dragonprime.net
lade 1.1.0 runter ;) und schon ist er da....

Autor:  -DoM [ Mo 09 Apr, 2007 15:22 ]
Betreff des Beitrags: 

Jaaaaa, von dieser Verison reden wir ja nicht...

Ich bin eigentlich der Meinung, das die LoGD-Inatalltion noch schwerer sein sollte, damit nicht gaaaaanz soviele Noobs denken, "Och das is ja OpenSource ich nu nauch mal eins"... Und legen den Webspace von Papas Familienseite lahm...*lach*

Autor:  Kevz [ Mo 09 Apr, 2007 16:19 ]
Betreff des Beitrags: 

Ja die SQL sollte man so verstecken das sie niemand findet und falls doch nur mit einer Altersverifizierung geöffnet werden kann. *hrhrhr*

Autor:  Nightborn [ Mo 09 Apr, 2007 20:19 ]
Betreff des Beitrags: 

-DoM hat geschrieben:
Ich bin eigentlich der Meinung, das die LoGD-Inatalltion noch schwerer sein sollte, damit nicht gaaaaanz soviele Noobs denken, "Och das is ja OpenSource ich nu nauch mal eins"... Und legen den Webspace von Papas Familienseite lahm...*lach*


^^ dann kommen sie und fragen, das ist alles schlimm.

ich seh hier ja auch genau so fragen wie auf dragonprime...wobei da auch leute waren, die nicht wussten, was ein zip file ist und wie man das öffnet... also... kommt wohl aufs ähnliche raus.
manche posten bevor sie denken -_- egal obs einfach oder schwer ist.

Autor:  Kevz [ Mo 09 Apr, 2007 20:25 ]
Betreff des Beitrags: 

Dafür gibt es ja Anpera.net bzw. Dragonprime ;)

Autor:  Patzue [ Mi 04 Aug, 2010 16:16 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Hey!

Ich poste es hier um nicht einen extra Thread aufzumachen.. Ich hab schonmal einen local Server am laufen gehabt auf XP aber. Bin auf Vista umgestiegen (fragt bitte nicht wieso :D) und nun kommt diese Fehlermeldung


Zitat:
You must edit the dbconnect.php file to set it up for your database.
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\xampp\htdocs\logd\dbwrapper.php on line 112

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in C:\Program Files\xampp\htdocs\logd\dbwrapper.php on line 73


2 Sachen verwirren mich. erstens.. dbconnect.php wurde richtig ausgefüllt

Code:
<?php
$DB_USER="root"; //Database Username
$DB_PASS="[...]"; //Database Password
$DB_HOST="localhost"; //Database Hostname
$DB_NAME="logd"; //Database Databasename

if ($DB_USER.$DB_PASS.$DB_HOST.$DB_NAME == ""){
   echo "You must edit the dbconnect.php file to set it up for your database.";
}
?>


Das PW lass ich jetzt hier extra weg ;)

und

Zitat:
user 'ODBC'@'localhost' (using password: NO)


?? Ich nutze doch den user root. Und benutze ein PW.

MySQL-Client-Version: 5.0.24a
phpMyAdmin Version: 2.9.0.1

Bin echt grad überfordert damit :P

Autor:  Tidus [ Mi 04 Aug, 2010 16:57 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

wieso schreibst du bitte die pma version dazu??? viel interessanter wäre die PHP version -.-*


Also ich tippe du hast das neue Xampp packages geladen mit php 5.3 und das ist für logd irgendwie nicht kompatibel bezgl. datenbank verbindung, aber da du das natürlich nicht dazu sagst kann ich nur raten.

Oder: Xampp verwendet standard mäßig soviel ich weis für die mysql dbs garkein passwort... [worauf das USING Password: No passen könnte]

Autor:  Patzue [ Mi 04 Aug, 2010 17:25 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Ach verdammt. Dachte, dass ich die PHP-Version dazu geschrieben habe

laut phpinfo()

PHP Version 5.1.6


Tidus hat geschrieben:
Oder: Xampp verwendet standard mäßig soviel ich weis für die mysql dbs garkein passwort... [worauf das USING Password: No passen könnte]


Hmm.. Hatte damit unter XP auch keine probleme.. Ich teste es mal ohne Passwort

Autor:  Kevz [ Mi 04 Aug, 2010 17:43 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Die XAMPP-Version hat kein MySQL Passwort gesetzt, deshalb kannst Du auch keine Verbindung zum Server aufbauen. Punkt. :-) Lass es weg, dann sollte es funktionieren.

Autor:  Patzue [ Mi 04 Aug, 2010 17:46 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Also wenn ich das Passwort aus der dbconnect entferne bekomme ich selben Fehler O.o Wie kann ich denn das Passwort von pma entfernen? Habe es ja über den Xampp eingerichtet :D

Edit: Habs gefunden. Klappt nun. Dankeschön

Seite 1 von 2 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/