anpera.net
http://anpera.homeip.net/phpbb3/

Problem mit dem Local Server
http://anpera.homeip.net/phpbb3/viewtopic.php?f=34&t=3488
Seite 2 von 2

Autor:  Linus [ Mi 04 Aug, 2010 18:28 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Öhhhm ... bist du sicher, dass du die dbconnect.php mit den richtigen Daten gefüttert hast?

Zitat:
Access denied for user 'ODBC'@'localhost' (using password: NO)

Hier wird nämlich nicht dem Datenbankuser "root", sondern dem User "ODBC" der Zugriff verweigert! :?

Autor:  Patzue [ Mi 04 Aug, 2010 18:32 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Zitat:
Zitat:
user 'ODBC'@'localhost' (using password: NO)


?? Ich nutze doch den user root. Und benutze ein PW.




Das hatte ich mich auch schon gefragt wie du siehst. Aber ich hab das hier

Patzue hat geschrieben:

$this->bbcode_second_pass_code('', '<?php
$DB_USER="root"; //Database Username
$DB_PASS="[...]"; //Database Password
$DB_HOST="localhost"; //Database Hostname
$DB_NAME="logd"; //Database Databasename

if ($DB_USER.$DB_PASS.$DB_HOST.$DB_NAME == ""){
echo "You must edit the dbconnect.php file to set it up for your database.";
}
?>
')
[/quote]

Direkt aus der dbconnetc kopiert. Nur eben das Passwort entfernt. Die DB heißt DEFINITIV logd

Und ich habe das Passwort mehr als einmal überprüft.

Aber nachdem ich das Passwort von pma/MySql über den Xampp zurückgesetzt habe und das PW aus der dbconnect.php entferrnt habe gings

Edit: Naja. Erst nachdem ich per php-switch.bat auf PHP 4.4.4 umgestellt habe.. Obwohl!! ich alle umstellungen von PHP4 auf PHP5 gemacht hate ;)

Autor:  Charon [ Do 05 Aug, 2010 13:20 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Hallo,
also ich hatte den Fehler anfangs, als ich übersehen hatte in der dbconnect.php das <? zu <?php zu ergänzen, was ja auch noch ein paar Files mehr betrifft. Aber dem geposteten code nach, ist das bei dir ja schon richtig. :hmpf:
Kannst ansonsten ja mal nur testweise die Variablen direkt in der common.php vor dem Linkaufbau einfügen.


@Tidus
Logd läuft bei mir lokal absolut problemlos mit XAMPP und php5.3
(die üblichen kleinen Änderungen müssen natürlich gemacht werden)

Autor:  Patzue [ Do 05 Aug, 2010 14:06 ]
Betreff des Beitrags:  Re: Problem mit dem Local Server

Ich war einfach stroh dumm :bash: :bash: eine winzige Änderung hatte ich übersehen..

Irgendwo im Forum (find es grad nicht) steht, dass man auch alle date("r") (waren es glaub ich) in date("c") umändern muss.. Das hatte ich aber erst seeeeehr spät und nach laaaaanger suche gefunden ;D

Seite 2 von 2 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/