anpera.net
http://anpera.homeip.net/phpbb3/

0.9.7 ext GER: Entwicklung eingestellt
http://anpera.homeip.net/phpbb3/viewtopic.php?f=26&t=531
Seite 1 von 1

Autor:  anpera [ Mo 09 Aug, 2004 02:34 ]
Betreff des Beitrags:  0.9.7 ext GER: Entwicklung eingestellt

Mit sofortiger Wirkung stelle ich die Weiterentwicklung der deutschen Version "0.9.7 ext GER" von Eric Steven's "Legend of the Green Dragon" ein. Der Grund ist der naherückende Release der neuen Version 0.9.8, für die es inzwischen jede Woche ein neues Pre-Releases für Entwickler gibt.
Das Umschreiben meiner Erweiterungen für die neue Version steht jetzt erstmal im Vordergrund, damit zum Release möglichst viele bekannte Funktionen aus ext GER für 0.9.8 zur Verfügung stehen. Die meisten meiner Module werden sich unter der neuen Version selbst zum Download anbieten, sobald sie fertig sind ('Über LoGD', Modulinfos). Alle anderen Modifikationen am Core-Code werden - wie es die Lizenz verlangt - auf DragonPrime veröffentlicht.

Bis zum offiziellen Release von 0.9.8 werde ich mich für 0.9.7 ext GER also auf Bugfixes und Support beschränken. Ein letztes ext GER Komplettpaket wird es im Laufe der nächsten Tage geben.

Sollte das Übersetzungstool in einem der nächsten Prereleases so funktionieren, wie es gedacht ist, kann auch mit der Übersetzung der fertigen Texte angefangen werden. Dafür werde ich mich dann aber nochmal melden und auf die zahlreichen Hilfsangebote zurückkommen. :)

Autor:  Zarzal [ So 22 Aug, 2004 19:23 ]
Betreff des Beitrags: 

Ist schon absehbar, ob es eine Updatemöglichkeit auf die neue Version geben wird oder ist die Datenbank so inkompatibel, das man alles neu aufsetzen muss und jeder bei 0 anfangen soll?

Gibt's das ungekündigte letzte 'neue' 0.9.7 Paket noch irgendwann zum download oder skippst Du das?

Gruß Zarzal

Autor:  anpera [ So 22 Aug, 2004 19:54 ]
Betreff des Beitrags: 

Also das versprochene Paket wird es noch geben. Demnächst. Nur nicht hetzen :P

Man wird das unmodifizierte 0.9.7er LoGD auf 0.9.8 updaten können, allerdings wird das mit 0.9.7 ext (GER) definitiv nicht funktionieren. Ich werde auch nichts in diese Richtung anbieten, da kaum jemand ext (GER) unmodifiziert verwendet und da nur Probleme auftreten würden.
Selbst meine eigenen Addons werden nach dem Konvertieren in 0.9.8-Module nicht mehr die Tabellen und Spalten benutzen, die sie jetzt nutzen, sondern die dafür vorgesehenen Modultabellen. Das Übertragen der Daten von der alten in die neue Version ist also mehr oder weniger Handarbeit, bei der sich jeder Admin selbst überlegen muss, ob er das durchführen will.

(Das item-system z.B. wird nach wie vor eine eigene Tabelle haben, allerdings komplett neu überarbeitet und nicht mehr zur alten Struktur kompatibel.)

Edit: Achso, falls du ein Update von ext (GER) auf die nächste ext (GER) meinst... da sieht es leider ähnlich aus. Automatische Updates oder eine Update-Anleitung ist nicht vorgesehen. Das wird besonders beim Passwort zuschlagen, denn mit dem nächsten Paket werden Passwörter nur noch als MD5-Hash gespeichert - und auch als solcher in der DB erwartet. Einige Felder gibt es nicht mehr (z.B. thefttoday) und andere wurden erweitert und verändert.
Aber mit den entsprechenden Kenntnissen (Vergleich der DB-Struktur mit der neuen DB-Datei) sollte ein manuelles Update auf das neue Paket möglich sein.

Autor:  Zarzal [ So 22 Aug, 2004 21:37 ]
Betreff des Beitrags: 

Das mit dem Passwort wollt ich als nächstes erwähnen, erübrigt sich jetzt :) Ich muss mal sehen, wenns soweit ist. Spiel neu aufsetzen und dann die Spieler manuel übertragen scheint mir das sinnvollste zu sein. Da das Passwort aber nun kodiert ist werde ich sie wohl bitten ihren Char selber anzulegen und ich modifiziere dann die Werte von Hand.

...bin schon gespannt.

Autor:  Tidus [ Di 02 Sep, 2008 18:09 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

ich weis das thema ist uralt aber, was spricht dafür die version zu wechseln? ich würde sonst bei der 097 bleiben wenn die 098 nicht so überragend viel besser ist ö.ö

Autor:  Rikkarda [ Di 02 Sep, 2008 18:31 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

sind fast alle :)

Autor:  Linus [ Di 02 Sep, 2008 19:04 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

Ich werde definitiv bei der 0.97er bleiben. So viel Arbeit steckt mittlerweile darin. Fast 2 Jahre Ausbau, Fehlerbereinigung und Codeoptimierung. Das Teil läuft wie geschmiert, die meisten meiner Spieler wissen gar nicht mehr wie eine Badnav aussieht. Schon die Vorstellung noch einmal von vorn anzufangen schmerzt. :shock:

Ich werd mir die 0.9.8 gerne mal ansehen, aber mein Dörfle auf die neue Version umrüsten werde ich nicht. ;)

Autor:  Eliwood [ Di 02 Sep, 2008 19:08 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

Wenn man schon einen Uralt-Thread ausgräbt, dann bitte auch aktuelle Informationen verwenden.
0.9.8 ist obsolet - Dragonprime ist bei 1.1.1 angekommen.

Autor:  Linus [ Di 02 Sep, 2008 19:19 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

Eliwood hat geschrieben:
Dragonprime ist bei 1.1.1 angekommen.


Zu 1.x.x fällt mir nur eines zu sagen ein: Wer ist eigentlich Paul? :D

Autor:  Nightborn [ Di 02 Sep, 2008 19:25 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

Zitat:
Das Teil läuft wie geschmiert, die meisten meiner Spieler wissen gar nicht mehr wie eine Badnav aussieht.


Laß sie bitte 2x F5 drücken, dann wissen sie es :)

Entgegen der landläufigen Meinung kommen badnavs nicht *UNBEDINGT* aus fehlerhaftem(=kaputt) Code.

In der Tat gibt es da lustige Racing Conditions und andere Gags, die das nach dem Wahrscheinlichkeitsprinzip krachen lassen...

Das Thema "Welche Version? 0.97 oder 1.x.x" wurde hier schon zig mal durchgekaut =)

Autor:  Linus [ Fr 05 Sep, 2008 19:16 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

Nightborn hat geschrieben:
Laß sie bitte 2x F5 drücken, dann wissen sie es :)

Entgegen der landläufigen Meinung kommen badnavs nicht *UNBEDINGT* aus fehlerhaftem(=kaputt) Code.


Browser aktualisieren ist wie Selbstmord, das ist mir schon klar. Aber setz mal die 0.97 ext ger neu auf, bau einige von den hier angebotenen Addons und Specials ohne Ändereungen ein und du brauchst F5 oder den Button "Aktualisieren" nicht mehr denn die badnavs kommen auch so reihenweise :D

Autor:  Nightborn [ Fr 05 Sep, 2008 19:24 ]
Betreff des Beitrags:  Re: 0.9.7 ext GER: Entwicklung eingestellt

:D niemand hat gesagt, daß alle hier angebotenen Teile super-sauber und fehlerfrei sind.

Seite 1 von 1 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/