anpera.net

anpera.net

experimental server @home
Aktuelle Zeit: Mi 18 Sep, 2019 12:56

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 8 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Kommentare zeigen: "..."
BeitragVerfasst: Di 05 Feb, 2008 00:14 
Offline
Eingeweihter
Eingeweihter
Benutzeravatar

Registriert: Mo 07 Mai, 2007 11:56
Beiträge: 65
Wohnort: Passau
LoGD: www.silberstrom-city.de
Ich wollte eben einen Farbcode einfügen (h) und dann kamen bei den Kommentaren auf allen Plätzen nur noch "..." Anstatt der Text der einst dort vorzufinden war. Lösch ich alle Kommis gehts wieder... aber sobald einer was schreibt wird es eben wieder so angezeigt, ich wüsste nichts was ich ansonsten angestellt haben könnte....

Bild


(Und sorry das ich ausversehen den Theard 2x erstellt, habe...einer kann dann ja gelöscht werden.)

_________________
Dattebayo


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Kommentare zeigen: "..."
BeitragVerfasst: Di 05 Feb, 2008 00:14 
Offline
Eingeweihter
Eingeweihter
Benutzeravatar

Registriert: Mo 07 Mai, 2007 11:56
Beiträge: 65
Wohnort: Passau
LoGD: www.silberstrom-city.de
Nojo, anstatt löschen gehts auch so. Edit by Eliwood.

_________________
Dattebayo


Zuletzt geändert von Eliwood am Di 05 Feb, 2008 16:50, insgesamt 1-mal geändert.
Zusammenführen von Beiträgen


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Kommentare zeigen: "..."
BeitragVerfasst: Di 05 Feb, 2008 01:49 
Offline
Eingeweihter
Eingeweihter
Benutzeravatar

Registriert: Mo 07 Mai, 2007 11:56
Beiträge: 65
Wohnort: Passau
LoGD: www.silberstrom-city.de
Zusatz, sagte mir ein User

Wenn ich auf eine Platz gehe wo ein Kommentar ist kommt erst noch folgende Fehlermeldung.
Warning: preg_replace() [function.preg-replace]: Compilation failed: range out of order in character class at offset 46 in /www/htdocs/muraki/common.php on line 1864

Hier die Zeilen 1863 bis 1865
$row = db_fetch_assoc($result);
$row[comment]=preg_replace("'[`][^".$appoencode_str."`]'","",$row[comment]);
$commentids[$i] = $row[commentid];

_________________
Dattebayo


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Kommentare zeigen: "..."
BeitragVerfasst: Di 05 Feb, 2008 02:39 
Offline
Lehrling
Lehrling

Registriert: Di 05 Dez, 2006 18:45
Beiträge: 46
LoGD: http://www.wolfsrealm.de
Wir haben inzwischen eine Not Lösung gefunden.
Haben es mit einer anderen common.php erst getestet, da kam im selben Bereich der Fehler.
Nun haben wir einfach das
$this->bbcode_second_pass_code('', ' $row[comment]=preg_replace("'[`][^".$appoencode_str."`]'","",$row[comment]);')
raus gelöscht und so gehen die Kommentare wieder.
Aber da ein Teil von der Einbauanleitung für die Farben ist, finden wir dass das keine Dauer Lösung sein sollte.

Dazu kommt das es im Profi ein Problem macht.

Warning: preg_replace() [function.preg-replace]: Compilation failed: range out of order in character class at offset 46 in /www/htdocs/muraki/prefs.php on line 245

Warning: preg_replace() [function.preg-replace]: Compilation failed: range out of order in character class at offset 46 in /www/htdocs/muraki/prefs.php on line 249

Das sind folgende 2 zeillen.
$this->bbcode_second_pass_code('', 'else $session['user']['prefs']['commenttalkcolor']=preg_replace("'[`][^".$appoencode_str."`]'","",substr($session['user']['prefs']['commenttalkcolor'],0,2));

else $session['user']['prefs']['commentemotecolor']=preg_replace("'[`][^".$appoencode_str."`]'","",substr($session['user']['prefs']['commentemotecolor'],0,2));')

Wir haben auch schon versucht alles raus zulöschen und es neu rein zumachen.

PS: Ich helfe Taiyo dort.

_________________
Entschuldigt wenn ihr so maches nicht versteht oder ich noch seltsam frage, ich bin erst dabei es zulernen und habe auch eine Lese-Rechtschreibschwäche.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Kommentare zeigen: "..."
BeitragVerfasst: Di 05 Feb, 2008 11:24 
Offline
Freak
Freak

Registriert: So 29 Jan, 2006 09:41
Beiträge: 1927
Wohnort: Schweiz
Geschlecht: Männlich
Skype: louis.huppenbauer
Welches neue Zeichen hast du denn hinzugefügt? Es gibt einige, die man so nicht einfach verwenden sollte. Lösche einfach mal die zuletzt erstellten Farbcodes. Zuerst den letzten, dann testen, u.s.w.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Kommentare zeigen: "..."
BeitragVerfasst: Di 05 Feb, 2008 11:52 
Offline
Eingeweihter
Eingeweihter
Benutzeravatar

Registriert: Mo 07 Mai, 2007 11:56
Beiträge: 65
Wohnort: Passau
LoGD: www.silberstrom-city.de
Zuletzt hab ich "h" eingefügt.
Der ist aber inzwischen weg, haben schon alle Farbcodes entfernt und neu rein gemacht, aber der Fehler ist weiterhin in der Bio...

Um genauer zu werden,
Im Profil, will man seine Standart Emotes und Gesprächsfarben eingeben, dann auf speichern klicken und dort tritt der Fehler mit der weißen Seite dann sofort auf.

_________________
Dattebayo


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Kommentare zeigen: "..."
BeitragVerfasst: Mi 06 Feb, 2008 02:20 
Offline
Eingeweihter
Eingeweihter
Benutzeravatar

Registriert: Mo 07 Mai, 2007 11:56
Beiträge: 65
Wohnort: Passau
LoGD: www.silberstrom-city.de
Kann geschlossen werden, ein Freund hat es mir repariert und es lag wirklich am falsch gewählten Farbcode für das Spiel. ^^

_________________
Dattebayo


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Kommentare zeigen: "..."
BeitragVerfasst: Mi 06 Feb, 2008 22:49 
Offline
Held
Held
Benutzeravatar

Registriert: Mo 17 Apr, 2006 08:39
Beiträge: 290
Wohnort: Lübeck
Geschlecht: Männlich
LoGD: http://antara-rosadrache.de
Skype: eichi-san
Nya, nich ganz, ich denke es lag an falscher Zeichenkodierung während des speicherns im Browser, die Zeichen wurden nämlich falsch gespeichert und so, kA wie das passieren konnte, aber im Extremfall direkt in der DB die Farbcodes wiederherstellen, und am Besten ein BackUp von den Farbcodes machen wenn man sie vollständig hat und sie funktionieren ^^

Blast

_________________
Ist es nicht die Weisheit, die ein Mensch zu erlangen sucht?!
Der Knochen kommt nicht von alleine zum Hund, schön wärs ._.

Schokopudding, der sich von alleine kochen kann.......


BLUBBBEL!


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 8 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen
Du darfst keine Antworten zu Themen in diesem Forum erstellen
Du darfst deine Beiträge in diesem Forum nicht ändern
Du darfst deine Beiträge in diesem Forum nicht löschen
Du darfst keine Dateianhänge in diesem Forum erstellen

Suche nach:
Gehe zu:  
cron
POWERED_BY
Deutsche Übersetzung durch phpBB.de
anpera.net - Impressum